United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Massachusetts and New Hampshire Court Holiday

Incident Report for Checkr US Data Status

Resolved

Massachusetts and New Hampshire courts have reopened and normal operations have resumed.
Posted Feb 18, 2025 - 14:57 UTC

Monitoring

Massachusetts and New Hampshire courts will close on Monday, February 17th, for Patriots' Day/Washington’s Birthday, affecting in-court research. Please anticipate delays. We are monitoring the situation.
Posted Feb 13, 2025 - 21:30 UTC