United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Cuyahoga, Ohio

Incident Report for Checkr US Data Status

Update

Cuyahoga County is down county wide due to a cyber attack at the municipal court level with no estimated time for restoration. Searches are not processing at this time for all of Cuyahoga County.
-- -- Cleveland:Municipal court is closed and has been taken offline due to a cyber attack with no estimated time for restoration.
-- -- Lakewood: Back online following a system update however now requires a piece of manual verification. Please anticipate delays as searches will be verified manually once Cuyahoga County is back online.

We are monitoring the situation and will keep this page updated accordingly.
Posted Mar 25, 2025 - 15:07 UTC

Update

We are continuing to monitor for any further issues.
Posted Mar 06, 2025 - 16:36 UTC

Monitoring

Due to various court site issues in Ohio, our usual automation processes are currently disrupted. This is affecting many Ohio counties, leading to statewide delays.

Temporarily Back Online and Processing:

Allen County: The Lima Ohio Municipal Court is down for maintenance and the implementation of a new Case Management System. The court is anticipating this update to take several months and searches may be delayed within this time period.


Counties Currently Not Processing Searches:

Cuyahoga County: Cuyahoga County is down county wide due to a cyber attack at the municipal court level with no estimated time for restoration. Searches are not processing at this time for all of Cuyahoga County.
-- -- Cleveland:Municipal court is closed and has been taken offline due to a cyber attack with no estimated time for restoration.
-- -- Lakewood: Back online following a system update however now requires a piece of manual verification. Please anticipate delays as searches will be verified manually once Cuyahoga County is back online. We are monitoring the situation.



Counties Delayed:
--Lake County: Processing is being done manually due to Captcha requirements affecting the automation.

--Licking County: The Court agent is back online, and processing is resumed however delays are anticipated while we work through the backlog.

--Jefferson County: Processing is being done manually due to Captcha requirements affecting the automation

--Lorain County: The Municipal Court agent is back online, and processing is resumed however delays are anticipated while we work through the backlog.

--Delaware County: The Court agent is back online, and processing is resumed however delays are anticipated while we work through the backlog.

--Wood County: The Court agent is back online, and processing is resumed however delays are anticipated while we work through the backlog.

We are monitoring the situation and will keep this page updated accordingly.
Posted Mar 04, 2025 - 15:08 UTC