United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Michigan - New Court Rulings
Incident Report for Checkr US Data Status
Resolved
Checkr is actively monitoring how this change to the Michigan courts will impact background checks. We will work with PBSA and our vendors to identify these impacts and will have more specific updates closer to the implementation date in July.
Posted Apr 20, 2021 - 19:10 UTC
Identified
New rulings across the state of Michigan revolving around the removal of PII (MCR 1.109(G)(9) and MCR 8.119(I)) are expected to go into effect on July 1st, 2021. The PII that may be impacted is DOB, SSN, Driver's License, Passport Numbers, and Financial Numbers. Researchers are being notified that some courts may begin removing PII sooner than July 1st. It appears will be more of a county-by-county and not one set process.

PBSA has confirmed they are sending a petition to have either wording revised, stop the new process, or give workarounds that will be efficient. We will continue to monitor this and be in communication with our vendors on final decisions.
Posted Apr 19, 2021 - 20:24 UTC