Data Status Page

This page contains information about third-party data source disruptions and delays.

Texas – MVR Processing Delays

Incident Report for Checkr Data Status

Resolved

The Texas state outage was resolved, and our connection was restored.
Posted Sep 17, 2026 - 21:13 UTC

Monitoring

Search processing in Statewide County, Texas is temporarily impacted. Searches are not currently processing; please expect delays once processing resumes. There is no ETA for resolution at this time.
Posted Sep 17, 2026 - 20:52 UTC