[Outage] OR DMV is Offline
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Jul 26, 2022 - 16:19 UTC
Monitoring
The OR DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Jul 25, 2022 - 21:43 UTC