United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Oklahoma DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 02, 2024 - 15:37 UTC
Identified
The Oklahoma DMV will be performing scheduled maintenance on Thursday, 5/2 from 5-8pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Apr 30, 2024 - 19:13 UTC