United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] NJ DMV is Offline
Incident Report for Checkr US Data Status
Resolved
The NJ DMV is back online and MVRs are once again processing as normal.
Posted May 08, 2024 - 17:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted May 08, 2024 - 17:51 UTC
Identified
The NJ DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted May 08, 2024 - 17:25 UTC