United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Mid-Atlantic Storm: Court Closures

Incident Report for Checkr US Data Status

Resolved

All courts have reopened, and normal processing has resumed. Expect delays as researchers work through the backlog.
Posted Feb 14, 2025 - 15:10 UTC

Update

The following are the latest court updates related to the winter storm:

Kentucky: All courts have reopened
Delaware: Courts are closed today
D.C.: Courts are experiencing delays
West Virginia: Greenbrier, Fayette, Hampshire, Hardy, Morgan, Pocahontas, and Raleigh courts are delayed, while Pendleton is closed.

We are actively monitoring the issue and will keep this page updated.
Posted Feb 12, 2025 - 16:00 UTC

Monitoring

Due to a winter storm in the Mid-Atlantic region, the following courts are closed on 2/11/2025. The storm is expected to continue through Wednesday, 2/12.

Kentucky: Estill, Jefferson

West Virginia: Boone, Greenbrier, Logan, Mercer, Mingo, Monroe, Pendleton, Pocahontas, Raleigh, Summers, Wyoming

We are actively monitoring the issue and will keep this page updated.
Posted Feb 11, 2025 - 15:37 UTC