United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Stanislaus, CA

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Mar 14, 2025 - 15:11 UTC

Monitoring

The court's system has been experiencing downtime for the past week. Currently, searches can only be processed at the clerk's window. Searches are completing but the court limits each researcher to 5 names or 5 cases per day. Please expect delays.
Posted Mar 13, 2025 - 17:35 UTC