United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Franklin and Hardin, KY Closure

Incident Report for Checkr US Data Status

Update

The Hardin County, KY courts have now reopened however the Franklin, KY courts are still experiencing issues. Please continue to anticipate delays as we work through the backlog. We are monitoring the situation.
Posted Apr 24, 2025 - 14:33 UTC

Update

The Franklin County, KY court remains closed through 4/18 and searches are not processing. We will continue to monitor the situation.
Posted Apr 18, 2025 - 13:41 UTC

Update

The Hardin County, KY court has reopened and searches have resumed. The Franklin County, KY court remains closed through 4/18 and searches are not processing. We will continue to monitor the situation.
Posted Apr 17, 2025 - 16:42 UTC

Monitoring

Due to court closures in Franklin and Hardin, Kentucky due to inclement weather - searches will not be processed. We are monitoring the situation.
Posted Apr 11, 2025 - 14:35 UTC