United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jun 10, 2024 - 15:56 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Saturday, 6/8
- Mississippi: 6am-2pm PT

Sunday, 6/9
- Louisiana: 7-10am PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Jun 07, 2024 - 21:28 UTC