United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closures] Courts Closed for Good Friday
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 05, 2021 - 15:07 UTC
Identified
04/01/2021: As of tomorrow, April 2nd, many courts across the United States will be closed in observance of Good Friday. Any courts that are closed and require in-court research will be inaccessible.

*This will not affect all reports*
Posted Apr 01, 2021 - 20:04 UTC