[Planned Outage] Idaho DMV Scheduled Maintenance
Incident Report for Checkr Data Status
Resolved
This incident has been resolved.
Posted Nov 17, 2022 - 18:24 UTC
Identified
The Idaho DMV will be performing scheduled maintenance today from 6-9pm PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Nov 16, 2022 - 23:34 UTC