[Outage] Maryland DMV is Offline
Incident Report for Checkr Data Status
Resolved
12/08/2021: The Maryland DMV is back online. Please expect some delays as orders begin being processed.
Posted Dec 08, 2021 - 16:45 UTC
Identified
12/07/2021: The Maryland online DMV is currently offline and MVRs are unavailable at this time. We are in contact with the state on how we can resolve this and will update you as we learn more.
Posted Dec 07, 2021 - 16:58 UTC