United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Anticipated Delay] Drug Screening: Tropical Storm Idalia

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Sep 18, 2023 - 20:21 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 13, 2023 - 20:00 UTC

Update

We are continuing to monitor for any further issues.
Posted Sep 06, 2023 - 21:38 UTC

Monitoring

We are anticipating potential service delays beginning Tuesday in Florida due to Tropical Storm Idalia. Drug testing turn around time and clinic availability may be impacted.
Posted Aug 29, 2023 - 15:57 UTC