United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Hurricane Helene Closures and Delays
Incident Report for Checkr US Data Status
Resolved
The impacted courts have reopened. Please anticipate delays as our researchers work through searches.
Posted Oct 01, 2024 - 19:23 UTC
Monitoring
The following courts in Florida and Georgia are closing due to the impending hurricane. Research will resume once the courts reopen. Please anticipate delays.

FL Courts:
COUNTY Closing Date Scheduled Reopen Date
Brevard, FL 9/26/2024 9/30/2024
Flagler, FL 9/26/2024 9/30/2024
Hardee, FL 9/26/2024 9/30/2024
Highlands, FL 9/26/2024 9/30/2024
Polk, FL 9/26/2024 9/30/2024
Putnam, FL 9/26/2024 9/30/2024
Seminole, FL 9/26/2024 9/30/2024
St. Johns, FL 9/26/2024 9/30/2024
Volusia, FL 9/26/2024 9/30/2024

GA Courts:
COUNTY Closing Date Scheduled Reopen Date
Atkinson, GA 9/26/2024 9/30/2024
Bleckley, GA 9/26/2024 9/30/2024
Brooks, GA 9/25/2024 (Noon) 9/30/2024
Cook, GA 9/26/2024 (Noon) 9/30/2024
Decatur, GA 9/26/2024 9/30/2024
Evans, GA 9/26/2024 (Noon) 9/30/2024
Lee, GA 9/26/2024 9/30/2024
Liberty, GA 9/26/2024 (Noon) 9/30/2024
Long, GA 9/26/2024 (Noon) 9/30/2024
Macon, GA 9/26/2024 9/30/2024
Mitchell, GA 9/26/2024 9/30/2024
Muscogee, GA 9/26/2024 (1pm) 9/30/2024
Pierce, GA 9/26/2024 (Noon) 9/27/2024 tentative
Quitman, GA 9/26/2024 9/30/2024
Randolph, GA 9/26/2024 9/30/2024
Seminole, GA 9/26/2024 9/30/2024
Sumter, GA 9/26/2024 (Noon) 9/30/2024
Talbot, GA 9/26/2024 9/30/2024
Tattnall, GA 9/26/2024 (Noon) 9/30/2024
Terrell, GA 9/26/2024 9/30/2024
Ware, GA 9/26/2004 (Noon) 9/30/2024
Tifton, GA 9/26/2024 9/27/2024 tentative
Worth, GA 9/26/2024 9/27/2024 tentative
Posted Sep 26, 2024 - 13:51 UTC