United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Kent, MI
Incident Report for Checkr US Data Status
Resolved
Kent MI District Court is back to normal operations. Please expect delays as the researchers catch up on searches.
Posted Sep 23, 2024 - 14:47 UTC
Monitoring
Kent MI District Court is temporarily unavailable due to software maintenance with no ETA for restoration. Searches cannot be completed at this time. We will continue to monitor the situation and notify you of any changes.
Posted Sep 12, 2024 - 16:23 UTC