United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Closure] Parker, TX & Nueces, TX
Incident Report for Checkr US Data Status
Resolved
The online index is offline in both Parker, TX and Nueces, TX. The new ETA for the system to be back up is 4/11/23. This closure affects all searches. Please expect delays.
Posted Apr 04, 2023 - 20:38 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 31, 2023 - 20:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 24, 2023 - 15:31 UTC
Update
We are continuing to monitor for any further issues.
Posted Mar 21, 2023 - 18:16 UTC
Monitoring
The online index is offline in both Parker, TX and Nueces, TX. The new ETA for the system to be back up is 4/11. This closure affects all searches. Please expect delays.
Posted Mar 15, 2023 - 01:45 UTC