United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Widespread outages due to security company CrowdStrike
Incident Report for Checkr US Data Status
Resolved
CrowdStrike has confirmed that the issues have been resolved on their end. Please expect some delays across jurisdictions that were affected as our researchers get through searches.
Posted Jul 25, 2024 - 22:29 UTC
Update
While CrowdStrike has confirmed that the issues have been resolved on their end, De Soto, MS remains unavailable. We will continue to monitor this jurisdiction closely and provide updates as we know more.
Posted Jul 24, 2024 - 16:13 UTC
Update
While CrowdStrike has confirmed that the issues have been resolved on their end, some courts continue to experience outages. Updates are below.

Criminal Records: We have confirmed that some counties across GA, DE, CA, MS, and NV remain offline. We are continuing to monitor closely and will update you as we know more.
Posted Jul 23, 2024 - 20:23 UTC
Update
While CrowdStrike has confirmed that the issues have been resolved on their end, some courts continue to experience outages. Updates are below.

Criminal Records: We have confirmed that various criminal jurisdictions remain unavailable in AZ, CA, DE, GA, MS, NV, and OH. We are closely monitoring this with our researchers and will continue to keep you updated.

Motor Vehicle Records: All DMVs have recovered and are processing.
Posted Jul 22, 2024 - 18:06 UTC
Update
While CrowdStrike has confirmed that the issues have been resolved on their end, some court and state DMV agencies continue to experience outages. This situation has changed significantly throughout the day, but we continue to see positive progress as agencies come back online.

Criminal Records: Various states and courts continue to experience outages. At this time, Kansas and Delaware are down across all counties. Arizona, California, Georgia, Michigan, Nevada, Ohio, Tennessee, Texas, and West Virginia all have one or more counties offline, but not full-state impact.

Motor Vehicle Records: Georgia and Iowa are still experiencing outages.

We remain committed to monitoring these outages and will provide updates as available.
Posted Jul 19, 2024 - 23:06 UTC
Monitoring
Motor Vehicle Records: Kansas DMVs have recovered and orders are processing. DMVs that are still experiencing outages include: Georgia, Iowa, and Wyoming.
Posted Jul 19, 2024 - 20:04 UTC
Update
We are continuing to work on a fix for this issue.
Posted Jul 19, 2024 - 17:57 UTC
Identified
Due to the widespread outages that occurred with the cybersecurity company CrowdStrike, please expect delays. We are continuing to partner with our researchers across the globe to ensure they are able to complete work as quickly as they can. We are closely monitoring this and will keep you updated.

Criminal Records: We have confirmed that some courts, including Los Angeles and Stanislaus, CA, are experiencing outages with their systems resulting in processing delays.

Motor Vehicle Records: We have confirmed that some DMVs are experiencing outages with their systems, resulting in processing delays. These DMVs include: Georgia, Iowa, Kansas, and Wyoming.

The following state DMVs experienced outages but have since recovered: Arizona, Delaware, Indiana, Louisiana, Maryland, New Jersey, Oklahoma, Pennsylvania, Rhode Island, Tennessee, and Virginia.

[Monitoring] International Records: The issue impacting International screenings has been resolved and we are currently monitoring system recovery.
Posted Jul 19, 2024 - 16:29 UTC