United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Oct 16, 2024 - 18:54 UTC
Monitoring
Medium Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--GA: The following counties remain closed due to the impact of Hurricane Helene, so please expect delays: Echols, Richmond, and Warren
--GA: Bibb - Currently only one public access terminal is functioning in State Court, while the second terminal is out of service with no estimated date for repair. We are processing searches but please anticipate delays.
--MI: Kent - The District Court public access terminal is currently down for maintenance, with no ETA for restoration. We are unable to process searches at this time, so please expect delays.
--MI: Ottawa - All searches now require clerk assistance due to limited information available on the public index. Clerks are restricting submissions to 5 names per day. Please anticipate significant delays.
--NV: Clark - The public access terminal is currently experiencing intermittent degradation and slowness, with no estimated time for repair. Please anticipate delays.

Low Impact

--LA: St Tammany - The courts have moved to in-court research. Please expect some continued delays.
--NV: Carson City - The Carson City District Court records clerk is behind on requests. Please expect delays.
--NY: Tioga - The research method changed in mid-March. Researchers used to be able to conduct research on a PAT, but now all requests must be submitted to the clerks. Clerks will only process 10 searches a day. Please anticipate delays.
Posted Oct 08, 2024 - 19:51 UTC