United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Scheduled Maintenance] - Washington
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 00:02 UTC
Identified
WA maintenance will occur February 10-11, 2024. County and statewide searches requested during this time will be processed as soon as the scheduled maintenance is complete. Please anticipate minor delays during the maintenance window.
Posted Feb 07, 2024 - 21:15 UTC