United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Dec 18, 2024 - 20:11 UTC
Monitoring
--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--GA: Bibb - The State Court in Bibb has only two PATs available, and researchers are facing constraints while gathering record information. We are processing searches but please anticipate delays.
--MI: Ottawa - All searches require clerk assistance due to limited PAT availability, and clerks are restricting submissions to five names per day. Please anticipate delays.


Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
Posted Dec 11, 2024 - 20:27 UTC