Data Status Page

This page contains information about third-party data source disruptions and delays.

Miami-Dade County, Florida – Court Processing Delays

Incident Report for Checkr US Data Status

Resolved

Resolved- normal operations have resumed.
Posted Jun 29, 2026 - 20:41 UTC

Update

Normal search processing has been restored. Please expect some delay as the queue recovers. On track for June 26th.
Posted Jun 25, 2026 - 04:51 UTC

Update

Search processing in Miami-Dade County is experiencing delays. The issue is under investigation; no ETA for resolution at this time.
Posted Jun 16, 2026 - 22:59 UTC

Update

Automation has been restored. Please expect some delay as the queue recovers. ETA is on track for June 15.
Posted Jun 09, 2026 - 20:47 UTC

Monitoring

Intermittent disruptions to court system access are impacting some automated search processing. Some searches may experience delays. No ETA for resolution at this time.
Posted Jun 08, 2026 - 19:52 UTC