United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Massachusetts – Court Closures due to Severe Weather

Incident Report for Checkr US Data Status

Resolved

Update 3/2: All Massachusetts courts have reopened. Please expect delays as the researchers work through the queue.
Posted Mar 02, 2026 - 22:10 UTC

Update

Courts in Barnstable, Bristol, and Plymouth counties remain closed today. All other Massachusetts courts are open and operating normally.
Posted Feb 26, 2026 - 21:35 UTC

Monitoring

All Massachusetts courts are closed February 23rd due to a winter storm. Searches will resume once courts reopen.
Posted Feb 23, 2026 - 21:35 UTC