United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delayed] - San Luis Obsipo, CA
Incident Report for Checkr US Data Status
Resolved
Searches are processing in San Luis Obispo, CA.
Posted Aug 08, 2024 - 19:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Jul 22, 2024 - 17:48 UTC
Monitoring
San Luis Obispo County, California removed the candidate’s date of birth (DOB) as search criteria in its criminal name search engines and court records. This removal affects both the courthouse kiosks and the court's website. This change impacts all Consumer Reporting Agencies, including Checkr, potentially leading to longer background check processing times. Please expect delays.
Posted Jul 09, 2024 - 00:32 UTC