United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] HI DMV is Delayed
Incident Report for Checkr US Data Status
Resolved
The HI DMV is back online and MVRs are once again processing as normal.
Posted Feb 03, 2025 - 13:00 UTC
Investigating
The Hawaii DMV is currently experiencing delays in completing MVRs. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Jan 30, 2025 - 17:52 UTC