Data Status Page

This page contains information about third-party data source disruptions and delays.

Kankakee County, Illinois – Court Processing Delays

Incident Report for Checkr Data Status

Update

The courts site has been restored and normal search operations have resumed. Please expect some residual delay as the queue normalizes.
Posted Aug 07, 2026 - 16:27 UTC

Update

The court's website is currently unavailable due to an internet service outage. Searches will resume once access is restored. No ETA for resolution at this time.
Posted Aug 06, 2026 - 01:05 UTC

Monitoring

System instability has taken some automated search processing offline. Please expect delays. No ETA for resolution at this time.
Posted Aug 05, 2026 - 21:05 UTC