United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Maryland Delays

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted 3 years ago. Sep 21, 2022 - 22:05 UTC

Update

8/29/2022; The Maryland online index is still experiencing major issues and there are delays for all searches. We are continuing to monitor this and work with our researchers to complete searches as quickly as possible.
Posted 3 years ago. Aug 29, 2022 - 17:03 UTC

Update

07/19/2022: The Maryland online index is still experiencing major issues and there are delays for all searches. We are continuing to monitor this and work with our researchers to complete searches as quickly as possible.
Posted 3 years ago. Jul 19, 2022 - 17:02 UTC

Monitoring

06/16/2022: The online index is experiencing issues in Maryland that are causing delays on all searches. We have confirmed that our vendors are working on completing the backlog as quickly as possible, but there is no ETA. We apologize for any inconvenience this may cause.
Posted 3 years ago. Jun 16, 2022 - 20:27 UTC