United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 29, 2024 - 16:37 UTC
Monitoring
We were just notified that these additional DMVs will be offline for maintenance this weekend:

- Kansas: Friday, 4/26 from 3-5pm PT
- South Carolina: Saturday, 4/27 from 5-8am PT
Posted Apr 26, 2024 - 20:50 UTC
Identified
The following DMVs will be performing scheduled maintenance this weekend during these times:

Tennessee: Friday, 4/26 from 7pm to Saturday, 4/27 at 1am PT

Sunday, 4/28
- Texas: 3-6am PT
- Rhode Island: 4:30-7am PT
- Mississippi: 6am-3pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Apr 26, 2024 - 20:16 UTC