United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 20:10 UTC
Monitoring
Medium Impact
--CA: Sacramento - Sacramento Superior Court has implemented a limit of 5 case file pulls per day for researchers. Please expect delays due to these court restrictions.
--GA: Bibb - Currently only one public access terminal is functioning in State Court, while the second terminal is out of service with no estimated date for repair. We are processing searches but please anticipate delays.
--MI: Ottawa - All searches now require clerk assistance due to limited information available on the public index. Clerks are restricting submissions to 5 names per day. Please anticipate significant delays.
--NV: Clark - The public access terminal is currently experiencing intermittent degradation and slowness, with no estimated time for repair. Please anticipate delays.
--OH: Lucas - The Common Pleas Court has moved to a new site. We are processing searches but please anticipate delays.

Low Impact
--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--OH: Lake - The Lake, OH Common Pleas Court has updated its public access terminals, which is causing integration issues. We are processing searches manually, so please expect delays.
Posted Oct 30, 2024 - 18:31 UTC