United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Washoe, NV County Searches
Incident Report for Checkr US Data Status
Resolved
We're fully caught up on the backlog in Washoe, NV. Clerk assistance is required for all searches now that automation is no longer viable for the Reno Justice Court. As such, please expect delays on a handful of searches.

Moving forward, our researchers will be working with the clerks to complete searches as quickly as possible.
Posted Jul 15, 2022 - 16:04 UTC
Monitoring
We've been making steady progress on the backlog in Washoe, NV. We anticipate being caught up within the next two weeks, but will keep you updated if anything changes.
Posted Jun 30, 2022 - 22:33 UTC
Identified
Unfortunately, for several weeks, automation has been unstable in Washoe, NV. We're sending researchers to the courts to conduct searches, but there are delays due to a significant backlog. In addition, all searches with potential hits require clerk assistance, causing further delays. We're working on completing the backlog as quickly as possible, but there is no ETA.
Posted Apr 21, 2022 - 20:35 UTC