United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] Maine DMV is Offline

Incident Report for Checkr US Data Status

Resolved

The Maine DMV is back online and MVRs are once again processing as normal.
Posted Jun 12, 2025 - 16:50 UTC

Investigating

The Maine DMV is currently offline and MVRs are unavailable at this time. The state is working on emergency maintenance and hope to have it resolved by June 11th. We will keep you updated as we learn more.
Posted Jun 10, 2025 - 16:02 UTC