United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Sep 14, 2022 - 16:13 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 9/11:

Pennsylvania: 12-6am PT
Florida: 4-9am PT
Georgia: 7-9am PT
Oklahoma: 10am-5pm PT

In addition, the Nevada DMV will be performing scheduled maintenance from Saturday, 9/10 at 8pm PT until Monday, 9/12 at 3am PT. MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Sep 09, 2022 - 21:54 UTC