United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[DELAY] WOOD, OH
Incident Report for Checkr US Data Status
Update
The Wood County Clerk of Courts is currently experiencing a county wide network issue and we are unable to process searches at this time. There is no ETA for restoration, but we are monitoring the situation and will provide updates as soon as we have more information.
Posted Dec 18, 2024 - 19:59 UTC
Monitoring
The Wood County Clerk of Courts is experiencing a county wide network issue and as a result we are unable to process searches at this time. There is no ETA for restoration and we are actively monitoring the situation.
Posted Dec 12, 2024 - 21:23 UTC