United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delayed] Berrien, MI
Incident Report for Checkr US Data Status
Update
We are continuing to monitor for any further issues.
Posted Jul 22, 2024 - 17:59 UTC
Update
Searches can be processed at this time but clerk assistance is needed. Please continue to expect delays.
Posted Jul 01, 2024 - 15:06 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 26, 2024 - 17:57 UTC
Update
We are continuing to monitor for any further issues.
Posted Jun 13, 2024 - 20:50 UTC
Update
We are continuing to monitor for any further issues.
Posted May 30, 2024 - 21:08 UTC
Update
We are continuing to monitor for any further issues.
Posted May 22, 2024 - 16:25 UTC
Update
The court has not completed the system update. There is currently no ETA for completion. Please continue to expect delays.
Posted May 02, 2024 - 22:08 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 30, 2024 - 22:21 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 25, 2024 - 16:29 UTC
Update
The court communicated that criminal and traffic requests won't be processed until after May 1, 2024. Please continue to expect delays.
Posted Apr 16, 2024 - 22:10 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 11, 2024 - 22:36 UTC
Update
We are continuing to monitor for any further issues.
Posted Apr 03, 2024 - 15:17 UTC
Monitoring
Berrien County Trial Court is pausing all criminal background checks starting March 28, 2024 for 2-3 weeks due to switching to a new computer system. At this time no criminal searches can be completed. Please expect delays.
Posted Mar 29, 2024 - 21:46 UTC