Data Status Page

This page contains information about third-party data source disruptions and delays.

Montana (Multi-County) – Court Processing Delays

Incident Report for Checkr Data Status

Resolved

Resolved - normal search processing has resumed.
Posted Aug 12, 2026 - 17:36 UTC

Update

Resolved – Automated search processing has been restored for Montana District and Justice Courts. Searches pending more than 72 hours will require additional research to complete as the backlog clears.
Posted Aug 05, 2026 - 16:06 UTC

Update

Some searches in Montana District and Justice Courts are experiencing delays due to a technical issue affecting automated search processing. Manual processing support is in place to help complete orders in the interim. No ETA for resolution at this time.
Posted Aug 05, 2026 - 00:14 UTC

Monitoring

Processing is experiencing a delay. Some searches may take longer than expected and may experience delays. No ETA for resolution at this time.
Posted Jul 09, 2026 - 16:47 UTC