United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] North Carolina System Migration
Incident Report for Checkr US Data Status
Resolved
Automation for all North Carolina counties is now enabled and processing. Please anticipate delays as the backlog is cleared.
Posted Feb 04, 2025 - 15:32 UTC
Update
North Carolina has confirmed that the Track 7 counties are now live: Bladen, Brunswick, Carteret, Columbus, Craven, Duplin, Jones, New Hanover, Onslow, Pamlico, Pender, Robeson, and Sampson. Counties not included in the migration are processing. We are actively working to restore automation for all counties and will continue monitoring the situation, providing updates as they become available.
Posted Feb 03, 2025 - 20:14 UTC
Update
North Carolina is transitioning additional counties to its new case management system, scheduled to go live on February 3rd.

Data from the following transitioning counties is current through January 29th: Bladen, Brunswick, Carteret, Columbus, Craven, Duplin, Jones, New Hanover, Onslow, Pamlico, Pender, Robeson, and Sampson.

Please note that North Carolina's systems will be unavailable from Friday, January 31st, at 5:00 PM until Monday, February 3rd.
Posted Jan 30, 2025 - 20:53 UTC
Monitoring
North Carolina is transitioning additional counties to their new case management system. Starting tonight, Wednesday, January 29th at 7:00 PM EST, data from the following counties will only be current through January 29th: Bladen, Brunswick, Carteret, Columbus, Craven, Duplin, Jones, New Hanover, Onslow, Pamlico, Pender, Robeson, and Sampson.

Please note that North Carolina’s systems will be unavailable from Friday, January 31st at 5:00 PM until Monday, February 3rd.
Posted Jan 29, 2025 - 17:51 UTC