United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] - Monroe, AR

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Feb 13, 2025 - 14:54 UTC

Update

There is new clerk in place to perform court duties in Monroe, Arkansas Clarendon District court. Please anticipate delays. We expect for searches to resume mid-week. We are monitoring the situation.
Posted Feb 10, 2025 - 22:23 UTC

Update

There is new clerk in place to perform court duties in Monroe, Arkansas Clarendon District court. Please anticipate delays. We are monitoring the situation.
Posted Feb 06, 2025 - 16:01 UTC

Update

There is new clerk in place to perform court duties in Monroe, Arkansas Clarendon District court. Please anticipate delays- we're anticipating processing to return to normal on 2/5/2025. We are monitoring the situation.
Posted Feb 04, 2025 - 16:39 UTC

Monitoring

There is no longer a clerk in place to perform court duties in Monroe, Arkansas Clarendon District court. Please anticipate delays and at this time, there is not an ETA on when things will return to normal. We are monitoring the situation.
Posted Jan 31, 2025 - 16:31 UTC