United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay] Polk, FL

Incident Report for Checkr US Data Status

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 21:21 UTC

Update

Polk, FL transitioned to a new website management system which resulted in searches being paused. We are now processing however please anticipate delays as we work through the backlog.
Posted Jun 12, 2025 - 19:18 UTC

Monitoring

Polk, FL has transitioned to a new website management system which has resulted in searches being paused. We are monitoring the situation.
Posted Jun 11, 2025 - 22:19 UTC