United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Weather Delay] - Multiple MS Counties
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 21:40 UTC
Monitoring
On April 10, 2024, severe weather conditions affected several counties in Mississippi, causing flooded roads and tornado watches. Please expect minor delays in the following counties.
* Jackson
* Forrest
* Jones
* Bolivar
* Washington
* Lauderdale
* Prentiss
* Lee
* Monroe
* Hinds
* Madison
Posted Apr 11, 2024 - 22:36 UTC