[Outage] PA DMV is Offline
Incident Report for Checkr Data Status
Resolved
The PA DMV is back online.
Posted Aug 05, 2022 - 21:00 UTC
Identified
The PA DMV is offline again and MVRs are currently unavailable. We are in contact with the state on how we can resolve this and will notify you of any changes.
Posted Aug 05, 2022 - 17:38 UTC