United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delays] Connecticut Courts
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 15, 2021 - 19:07 UTC
Identified
11/2/2021: The courts across the state of Connecticut are seeing significant delays due to the court clerk's backlogs and record verifying process. Please note that the majority of clear searches should be completed quickly, but expect candidates with potential records to take 2 weeks or longer to complete. We will continue to monitor this and notify you of any changes.
Posted Nov 02, 2021 - 16:47 UTC