United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

Planned Outage - Riverside, CA
Incident Report for Checkr US Data Status
Update
The Riverside Superior Court court will have scheduled maintenance on their case management system on Friday 01/17/2025 5:00 pm to Tuesday 01/21/2025 8:00 am PST. During this time, we will be unable to process orders.
Posted Jan 15, 2025 - 16:34 UTC
Identified
Riverside, CA is transitioning case management systems on 1/21/2024. Please anticipate delays.
Posted Jan 14, 2025 - 21:48 UTC