United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Delay - Coronavirus] Full List of Known Court Closures
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 01, 2021 - 19:29 UTC
Update
Please be aware that we have updated the link to the court closure page. We are no longer using the spreadsheet. Instead, we are using the link listed below.
Posted Apr 09, 2020 - 17:04 UTC
Identified
Due to the volume of court closures, we will be updating the below link with newly identified closures in real time. Please refer to the link below for all identified court closures going forward.

https://courts.checkrstatus.com/
Posted Mar 17, 2020 - 19:13 UTC