United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

5/11/2023: General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted May 15, 2023 - 23:26 UTC
Monitoring
High Impact

--SC: All Counties - The online system is experiencing issues and all searches must be conducted by the clerks. Expect delays.
--CA: San Bernardino - DOB is no longer available on the online index. Searches with possible cases must be conducted by the clerks, expect delays.
Sacramento - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.

Medium Impact

--CA: San Joaquin - Searches with possible cases must be conducted by the clerks and there are in-court restrictions causing major delays.

Low Impact

--AZ: Pima - Searches must be conducted by the clerks and there are in-court restrictions causing delays.
-- KY: Jefferson - In court research has been restricted due to recent court closures, please expect delays for the next 1-2 weeks.
Posted May 11, 2023 - 18:34 UTC