United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

2/9/2024: General Court Delays
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Feb 14, 2024 - 01:03 UTC
Monitoring
** Please note that several courthouses will be closed on Monday, February 12th in observance of Lincoln's birthday.**

High Impact

--CA: San Bernardino - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.

Medium Impact

--CA: Los Angeles - Site instability caused slowdown in searches being processed. Please expect delays.
--CA: San Joaquin - Researchers are facing in-court limitations and have to rely on clerk assistance for searches to be completed. Please expect delays.
--NH: All counties - Courthouses are experiencing staffing issues. Please expect delays.
--TX: Harris - Site instability caused slowdown in searches being processed. Please expect delays.
Posted Feb 09, 2024 - 01:10 UTC