United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

TN DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Jul 30, 2024 - 18:37 UTC
Identified
The TN DMV will be performing scheduled maintenance this evening from 10PM - 4AM PT. MVRs requested during this time will not be completed until the scheduled maintenance is done.
Posted Jul 26, 2024 - 19:07 UTC