United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Planned Outage] Weekend DMV Scheduled Maintenance
Incident Report for Checkr US Data Status
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 17:42 UTC
Identified
The following DMVs will be performing scheduled maintenance during these times on Sunday, 11/13:

Pennsylvania: 12-6am PT
Texas: 3-7am PT
Kentucky: 6-9am PT
South Carolina: 3-7pm PT

MVRs requested during these times will not be completed until the scheduled maintenance is done.
Posted Nov 11, 2022 - 19:52 UTC