[Outage] New Jersey DMV is Offline
Incident Report for Checkr Data Status
Resolved
The New Jersey DMV is back online and MVRs are once again processing as normal.
Posted Nov 03, 2022 - 19:50 UTC
Identified
The New Jersey DMV is currently offline and MVRs are unavailable at this time. We are working on a resolution and will notify you of any changes.
Posted Nov 03, 2022 - 17:19 UTC