United States Data Status Page

This page contains information about closures and delays in the US. For global updates, please subscribe to global.checkrstatus.com

[Outage] New Jersey DMV is Offline
Incident Report for Checkr US Data Status
Resolved
07/12/2021: The New Jersey DMV is back online and searches can now be completed.
Posted Jul 12, 2021 - 16:35 UTC
Investigating
The New Jersey DMV is offline and MVRs are not currently available in the state. We are in communication with the state and will provide updates as we receive them.
Posted Jul 09, 2021 - 18:47 UTC